API and Test History Outage
Incident Report for Webpagetest
Resolved
This incident has been resolved. UPDATE AS OF 10/26: The test history for all manual tests from during this incident have been added to the database. Only the "Run By" field is empty, everything else has been successfully backfilled.
Posted Oct 25, 2021 - 17:15 UTC
Monitoring
Due to a misconfiguration, the API was unable to authenticate and test results were not showing in the test history, starting at 5:00 PM EDT on October 23. We've identified the issue and applied the fix. We're working on backfilling all manual test data during the down period.
Posted Oct 25, 2021 - 13:48 UTC
Identified
We've identified an issue with the test history not returning new tests, and tests run via the API not being able to run (manual testing still works as expected). We're working on a fix.
Posted Oct 25, 2021 - 13:32 UTC
This incident affected: API and Management Portal.